Subscriptions inaccurate billing error
Resolved
Degraded performance

The incident is fully resolved and all refunds have been issued

Fri, Sep 6, 2024, 04:25 PM
1 month ago
Affected components
Bold Subscriptions
Updates

Resolved

The incident is fully resolved and all refunds have been issued

Fri, Sep 6, 2024, 04:25 PM
1 week earlier...

Monitoring

Aug 26th Update: If you were affected by duplicate billing charges in August, please be advised we have sent out communication to all affected merchants with the resolution steps. The issue with incorrect usage billing has been resolved, therefore, transaction fees have resumed effective August 20th, 2024. We would like to thank everyone for their patience in this matter

Mon, Aug 26, 2024, 04:56 PM
1 week earlier...

Investigating

If you were affected by duplicate billing charges in August, please be advised we are working with Shopify to resolve the issue. We have paused all usage billing while we work with Shopify. We expect to provide an update via email by Aug 15th. We apologize for the inconvenience.

Tue, Aug 13, 2024, 06:51 PM
3d earlier...

Investigating

If you were affected by duplicate billing charges in August, please be advised we are working with Shopify to resolve the issue. We have paused all usage billing until further notice. We will provide an update via email by Aug 13th. We apologize for the inconvenience.

Fri, Aug 9, 2024, 09:25 PM