3rd Party Issue With United States Postal Service
Resolved
Degraded performance
Lasted for 4h

This issue has now been resolved.

Tue, Mar 10, 2020, 01:55 AM
4 years ago
Affected components
Updates

Resolved

This issue has now been resolved.

Tue, Mar 10, 2020, 01:55 AM
4h earlier...

Identified

The issue has been identified and a fix is being implemented.

Mon, Mar 9, 2020, 09:53 PM

Investigating

We are currently having an issue with one of our 3rd part integrations for United States Postal Service, we are monitoring the situation with our 3rd party and will update when there is more information.

Mon, Mar 9, 2020, 09:52 PM